id: Гость   вход   регистрация
текущее время 23:19 24/10/2020
Автор темы: Гость, тема открыта 22/06/2007 19:33 Печать
https://www.pgpru.com/Форум/Содействие/ErrorOnKonqueror-решено
создать
просмотр
ссылки

error on konqueror – [решено]


Дело тут такое.
Невозможна навигация по сайту под этим замечтельным браузером.


При нажатии ссылки на какую-нибудь статью, браузер редиректится с короткого латинского адреса вида на длинный русский вида который отображается крякозябрами.


При этом заголовк страницы имеет вид


Причём с другими "вики", такими как http://ru.wikipedia.org/wiki/


Подобных проблем не наблюдается.

=====================


 
На страницу: 1, 2 След.
Комментарии
— SATtva (22/06/2007 20:05)   профиль/связь   <#>
комментариев: 11552   документов: 1036   редакций: 4094
Вопрос на понимание: проблема возникает только при открытии ссылок наподобие https://www.pgpru.com/Comment16246? Если Вы напрямую переходите на https://www.pgpru.com/Новости/.....s=1&p=1#Comment16246, то комментарий открывается корректно?
— sentaus (22/06/2007 20:24)   профиль/связь   <#>
комментариев: 1060   документов: 16   редакций: 32
Подтверждаю. Похоже, баг проявляется при любом клиентском редиректе.
— Гость (22/06/2007 20:59)   <#>
Пояснения.

В SeaMonkey ссылка на данную тему отображается как

после её вставки в адресную строку konquerora она принимает вид:

где знаки вопроса – квадратики. Страница загружается исправно.

Далее, отвечаю на Ваш вопрос.
Первая ссылка приводит к несуществующей (точнее несуществовашей) странице.
Вторая ссылка
открывается исправно
— Гость (22/06/2007 21:02)   <#>
Причем при открытии второй ссылки в адресной строке konqueror'a всё читабельно, а именно
— Гость (22/06/2007 21:10)   <#>
Позволю себе ещё одно дополнение.
При вставке в адресную строку ссылки вида

Так же не наблюдаются какие-либо проблемы, то есть всё нормально.
— Гость (22/06/2007 21:24)   <#>
И ещё, при ответе ответе на Ваш вопрос ссылки открывались непосредственно из konqueror'a.

Если же скопировать вторую ссылку из SeaMonkey, и затем вствить в konqueror, то страница открывается, но в адрессной строке наблюдаются квадратики.

К тому же, стоит добавить, что ранее (до приблизительно середины июня) передвигатся по сайту в konquerore было весьма возможно, хотя и не очень удобно, изза нечитабельности (квадратики) в адресной строке. Тогда несуществующая страница загружалась только после отправления комментария. И чтобы снова увидеть топик со своим коментарием приходилось возвращаться назад и обновлять страницу.

По моему скромному мнению, очевидно, есть проблемы как у конкверора (с перекодировкой адресной строки), что не так существенно, так и у сайта, что гораздо существенней.
— SATtva (23/06/2007 11:53)   профиль/связь   <#>
комментариев: 11552   документов: 1036   редакций: 4094
Определённое исправление я внёс, посмотрите, каковы результаты. Изменилось ли что-нибудь в поведении браузера?
— serzh (23/06/2007 12:55)   профиль/связь   <#>
комментариев: 232   документов: 17   редакций: 99
У меня не открывается (Konqueror 3.5.5).
Кстати в IceWeasel (2.0.0.4) такая же проблема, т.е. ссылка "https://www.pgpru.com/Comment16246" отображается как "https://www.pgpru.com/%CD%EE%E.....s=1&p=1#Comment16246"
Система Debian GNU/Linux 4.0.
— SATtva (23/06/2007 13:26)   профиль/связь   <#>
комментариев: 11552   документов: 1036   редакций: 4094
Дубль 2. Попробуйте ещё раз.
— serzh (23/06/2007 13:52)   профиль/связь   <#>
комментариев: 232   документов: 17   редакций: 99
Открывает с квадратами, но если открыть во внутреннем просмотре Akregator (RSS), то всё хорошо (до этого были проблемы).
В IceWeasel ничего не изменилось.
— SATtva (23/06/2007 13:58)   профиль/связь   <#>
комментариев: 11552   документов: 1036   редакций: 4094
Я имею в виду, нет ли чего-то наподобие отмеченного Гостем в начале темы?
— serzh (23/06/2007 14:02)   профиль/связь   <#>
комментариев: 232   документов: 17   редакций: 99
Этого уже нет.
— Гость (23/06/2007 14:17)   <#>
Повторный тест, дал следующие результаты (in vivo):
По первой ссылке страница теперь открывается но в адресной строке квадратики.
По второй ссылке страница отрывается, адресная строка в норме.

При вставке ссылок в адресную строку (через буфер обмена):
По первой ссылке страница открывается, но в адресной строке квадратики.
По второй ссылке страница отрывается, но в адресной строке квадратики.

Все ссылки на сайте кроме второй тестовой дают квадратики в адресной строке konqueror'а.
Я так понимаю, что они все вида


На счёт отправления комментария и последующего редиректа, отпишусь непосредственно после этого коммента.

Так же имею сообщить об отсутствии панели форматирования на форме быстрого ответа.
Но сначала проверю этот сайт при различных настройках JAVA/JS, может что-то не так у меня, а не у сайта. Если не поможет, то попробую поменять идентификацию на Safari.

Кстати на счёт идентификации. Какие поля UserAgent требуются для корректной работы с движком сайта? Нижеследующего достаточно?

Или ещё что-нить указать? (тогда на безопасности/анонимности скорее всего отразится).
— Гость (23/06/2007 14:20)   <#>
Отписываюсь насчёт редиректа после отправки коммента:
страница топика с добавленным топиком загрузилась
— Гость (23/06/2007 14:36)   <#>
Если прикинуться Safari 2, ( в данном случае ),
то панель форматирования имеет место быть.
Может и для konqueror'a впишите настройки аналогичные Safari? (хотя это меньше всего беспокоит)
На страницу: 1, 2 След.
Ваша оценка документа [показать результаты]
-3-2-1 0+1+2+3