id: Гость   вход   регистрация
текущее время 21:18 17/11/2018
Владелец: SATtva (создано 28/11/2006 14:50), редакция от 28/11/2006 15:02 (автор: SATtva) Печать
Категории: софт, gnupg, уязвимости, исходные тексты
http://www.pgpru.com/Новости/2006/11-28-ПереполнениеБуфераВGnuPG14xИ20
создать
просмотр
редакции
ссылки

28.11 // Софт // Переполнение буфера в GnuPG 1.4.x и 2.0


Важность: Ниже средней


В ходе исправления других багов, в коде всех выпущенных версий GnuPG была выявлена ошибка переполнения буфера. Она может привести к аварийному завершению программы, если для обработки будет представлено особым образом скомпонованное сообщение. При этом программа должна работать во взаимодействии с пользователем; если GnuPG функционирует в автономном режиме или как бэкенд к другим приложениям, он не подвержен ошибке. Возможно ли выполнение произвольного кода, в официальном сообщении разработчиков не уточняется, что, по-видимому, означает "нет".


Для устранения ошибки можете установить прилагающийся ниже патч (он применим как к последним версиям GnuPG, так, вероятно, и к более ранним) либо дождаться выхода исправленной версии программы.



Источник: http://www.gnupg.org


 
Один комментарий [показать комментарии/форму]
Ваша оценка документа [показать результаты]
-3-2-1 0+1+2+3