id: Гость   вход   регистрация
текущее время 16:32 14/12/2019
Автор темы: Kent, тема открыта 02/03/2004 01:10 Печать
создать
просмотр
ссылки

Вышел GnuPG 1.3.5


Вышла новая версия GnuPG для Linux, GnuPG 1.3.5 (development).


 
Комментарии
— Kent (02/03/2004 23:03)   профиль/связь   <#>
комментариев: 437   документов: 30   редакций: 15
Перевод вышеизложенного сообщения:

Новейшая версия нестабильной ветки GnuPg готова для публичного изучения.
Данная ветка – промежуточный вариант на пути к новой стабильной версии 1.4.
Она подвержена частым изменениям, в отличие от ветки 1.2.x, новые версии
которой содержат, в основном, исправления ошибок.

Продвинутые пользователи могут изучать данную версию и сообщать обо всех
ошибках gnupg-devel@gnupg.org. Взамен Вы получите новейший код со всеми
посленими нововведениями.

Настоящая версия GnuPG приближается к стабильному релизу 1.4.
Если Вы имеете предложения (претензии) к интерфейсу, новым
возможностям и т.п., то все Ваши предложения лучше высказывать
прямо сейчас, т.к. после стабилизации ветки 1.3.x внесение
существенных изменений не гарантируем.

Как обычно, учтите, что данный код достаточно стабилен для общего
применения, но всё еще остается дорабатываемой веткой. Для критических
применений используйте стабильную ветку 1.2.x.

Файлы доступны здесь:

или
или

Контрольные суммы MD5:

e6b35d22f529ad8a625e46cdf224f1b0 gnupg-1.3.5.tar.gz
c4b00adc6886cb2756124b3c46f3f677 gnupg-1.3.5.tar.bz2
3074a3f469e22ad9d836a8fd909f1d8a gnupg-1.3.4-1.3.5.diff.gz

Заслуживающие внимания изменения в 1.3.5 (2004-02-26)


    • Новый параметр min-cert-level позволяющий не принимать во внимание
      сертифицирующие подписи ниже заданного уровня.

    • Новый параметр --max-output ограничивает количество текста
      создаваемого GnuPG. Данный параметр можно использовать с программами,
      которые вызывают GnuPG для обработки сообщений, которые могут могут
      выдать текста большего размера, чем может обработать программа.
      Иногда это называется "Decompression Bomb".

    • Новая команда --list-config для программ оболочек (frontends) и других
      вызывающих GnuPG программ. См. doc/DETAILS.

    • Немного улучшена производительность обработки больших связок ключей.
      См. --enable-key-cache=SIZE в файле README.

    • Улучшена портируемость на некоторые платформы OpenBSD/i386, HPPA и AIX.

    • Новый параметр в keyserver-option "http-proxy" задает какой прокси
      использовать – в файле настроек, без применения переменных окружения.

    • Добавлена поддержка хранения (storing), получения (retrieving) и поиска
      ключей на LDAP серверах. Учтите, что это не "LDAP keyserver", которые
      уже поддерживаются.

    • Добавлена поддержка TLS и LDAPS сессии шифрования LDAP.

    • --show-session-key/override-session-key теперь работает с
      • -symmetric messages.

    • Параметры configure --enable-rsa и --disable-rsa могут теперь
      использоваться для вкл/искл поддержки RSA. Это может быть полезно
      для встраиваемых приложенией, где необходим минимальный размер приложения.
      • -enable-minimal включает --disable-rsa.

    • Удалена последняя поддержка Elgamal ключей подписи+шифрования.

Команда GnuPG (David, Stefan, Timo и Werner)
Ваша оценка документа [показать результаты]
-3-2-1 0+1+2+3